Product Page
Download :: Psychomancer
Macintosh UNIX/Linux Windows
System Requirements
Psychomancer 1.0.7 is available for Mac OS X 10.4 and later on PowerPC and Intel-based macs.

Psychomancer 1.06 is available for Mac OS 8 - X (PowerPC), Digital UNIX, Linux (x86), and Windows (98 - XP).